Project

General

Profile

Defect #885

Unable to work with TAGS

Added by vincent auroch over 8 years ago. Updated over 8 years ago.

Status:
終了(Closed)
Priority:
通常(Normal)
Assignee:
Target version:
-
Start date:
11/25/2011
Due date:
% Done:

100%

Estimated time:

Description

Hello,

We are currently unable to use the TAG feature of WE pluggin, and we would like to understand why.

When editing wiki page there is a dedicated section at the botom of wiki pages.
When saving wiki pages with "Save" then edit again, it sound that TAGs are not stored.
When playing with tag macros does not give any result.

Shall I missed something about TAG use ?

Thanks

#1

Updated by Haru Iida over 8 years ago

  • Status changed from 新規(New) to 担当(Assigned)
  • Assignee set to Haru Iida
#2

Updated by Haru Iida over 8 years ago

  • Project changed from r-labs to Wiki Extensions
#3

Updated by Haru Iida over 8 years ago

Hi.

What version of Wiki Extensions Plugin and Redmine do you use ?

#4

Updated by vincent auroch over 8 years ago

Hello Haru, how are you ?

We are running WE 0.3.2.

Your question is nice, because according to me this question of "source version" is a big default of redmine.
When entering trackers, it should be possible to specify the "source version" and not only the target version.

I added it as a custom field inside my own redmine, but it's not as confortable as the "target version combo" because I don't knwon how to set-up a drop-down box pre-filled with the list of existing versions.

vince

#5

Updated by vincent auroch over 8 years ago

Hello,

I had a quick look inside the log file, some strange records I'm not able to solve alone :

  • No route matches "/plugin_assets/redmine_wiki_extensions/javascripts/tablesort.js"
  • No route matches " /plugin_assets/redmine_wiki_extensions/stylesheets/wiki_extensions.css"
  • No route matches "/plugin_assets/redmine_wiki_extensions/javascripts/wiki_smiles.js"

Did we missed something ?

#6

Updated by Haru Iida over 8 years ago

vincent auroch は書きました:

Hello,

I had a quick look inside the log file, some strange records I'm not able to solve alone :

  • No route matches "/plugin_assets/redmine_wiki_extensions/javascripts/tablesort.js"
  • No route matches " /plugin_assets/redmine_wiki_extensions/stylesheets/wiki_extensions.css"
  • No route matches "/plugin_assets/redmine_wiki_extensions/javascripts/wiki_smiles.js"

Did we missed something ?

REDMINE_INSTALL_DIR/public/plugin_assets is writable?
REDMINE_INSTALL_DIR/public/plugin_assets/redmine_wiki_extensions/javascripts/*.js are exists?

#7

Updated by vincent auroch over 8 years ago

REDMINE_INSTALL_DIR/public/plugin_assets is writable >> yes
REDMINE_INSTALL_DIR/public/plugin_assets/redmine_wiki_extensions/javascripts/*.js are exists? >> yes

As you can see with those 2 URLs, the content inside /plugin_assets/redmine_wiki_extension/ looks like correct, and can be fetched by apache.

https://tracker.seasidetech.net/plugin_assets/redmine_wiki_extension/images/check.png
https://tracker.seasidetech.net/plugin_assets/redmine_wiki_extension/javascripts/tablesort.js

Here is the full log when the error occurs :

ActionController::RoutingError (No route matches "/plugin_assets/redmine_wiki_extensions/javascripts/wiki_extensions.js" with {:method=>:get}):
/usr/lib/ruby/1.8/phusion_passenger/rack/request_handler.rb:92:in `process_request'
/usr/lib/ruby/1.8/phusion_passenger/abstract_request_handler.rb:207:in `main_loop'
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:418:in `start_request_handler'
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:358:in `handle_spawn_application'
/usr/lib/ruby/1.8/phusion_passenger/utils.rb:184:in `safe_fork'
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:354:in `handle_spawn_application'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `__send__'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `main_loop'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:163:in `start'
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:213:in `start'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:262:in `spawn_rails_application'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:126:in `lookup_or_add'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:256:in `spawn_rails_application'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:80:in `synchronize'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:255:in `spawn_rails_application'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:154:in `spawn_application'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:287:in `handle_spawn_application'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `__send__'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `main_loop'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
/usr/lib/phusion_passenger/passenger-spawn-server:61

It sound there is a kind of "route" question regarding access to this directory, with maybe something wrong

#8

Updated by vincent auroch over 8 years ago

Hello

I have solved the issue by myself. Have a look :

/plugin_assets/redmine_wiki_extension*s*/javascripts/wiki_extensions.js

https://tracker.seasidetech.net/plugin_assets/redmine_wiki_extension/images/check.png

Just apologize for the trouble

Vincent

PS : this can be closed, thanks

#9

Updated by Haru Iida over 8 years ago

  • Status changed from 担当(Assigned) to 終了(Closed)
  • Target version deleted (0.3.7)
  • % Done changed from 0 to 100

Also available in: Atom PDF