Project

General

Profile

Defect #1168

some features fail with ruby 1.8.7

Added by Toshiyuki Ando almost 7 years ago. Updated almost 7 years ago.

Status:
新規(New)
Priority:
通常(Normal)
Assignee:
-
Target version:
-
Start date:
01/14/2013
Due date:
% Done:

0%

Estimated time:

Description

somthing wrong with capybara?
find("#latest-build-1").text returns "# / /"

find("#latest-build-1").base Capybara::RackTest::Node
find("#latest-build-1").base.text # / /
find("#latest-build-1").base.native Nokogiri::XML::Element
find("#latest-build-1").native Nokogiri::XML::Element
find("#latest-build-1").native.text #3 SUCCESS 2009/07/19 20:33:35

Capybara::RackTest::Node とその周辺が怪しそうだけど、それ以上追うのが面倒なので、この辺で終了。
1.8.7 でテストが通らないのなんかいやだけども。

History

#1

Updated by Toshiyuki Ando almost 7 years ago

  • Subject changed from some feature doesn't work with ruby 1.8.7 to some features fail with ruby 1.8.7
  • Description updated (diff)

Also available in: Atom PDF